Ben's 2.x Laser Build

Post your build logs here

Re: Ben's 2.x Laser Build

Postby sliptonic » Sat Sep 06, 2014 5:20 pm

Ben,
Did you ever complete the transition to the mesa 5i25 card? I'm in the process of moving mine to that card and I'm wondering if you implemented a watchdog/charge pump.

The mesa card outputs are high before any configuration loads so if linucnc is NOT running at all, pin 17 is high and the laser fires. Obviously this is a safety problem. I posted to the linuxcnc forum and it looks like this is by design and a watchdog is the right way to go. Anyone else using a 5i25 with the buildlog pololu breakout board?
sliptonic
 
Posts: 30
Joined: Sun May 16, 2010 6:02 pm
Location: Missouri

Re: Ben's 2.x Laser Build

Postby jv4779 » Sun Sep 07, 2014 9:28 pm

I don't see why you couldn't output the charge pump signal on a mesa output pin coming from the standard chargepump linuxcnc module. I have a charge pump in my config that is wired to a small board from cnc4pc that enables my parallel port breakout board.
jv4779
 
Posts: 40
Joined: Fri Dec 09, 2011 10:54 pm

Re: Ben's 2.x Laser Build

Postby sliptonic » Mon Sep 08, 2014 12:39 pm

I was looking at that CNC4PC board. Do you have any pictures of how it all goes together?
sliptonic
 
Posts: 30
Joined: Sun May 16, 2010 6:02 pm
Location: Missouri

Re: Ben's 2.x Laser Build

Postby jv4779 » Mon Sep 08, 2014 7:49 pm

Image

It was a little tricky getting the charge pump signal from the breakout board as it didn't want to output it until the enable pin was set, but the charge pump needed to be detected to do the enable. I ended up just tracing the change pump signal from the DB25 and soldering to it before the output buffers so I could see the signal even if the breakout board wasn't enabled yet.
jv4779
 
Posts: 40
Joined: Fri Dec 09, 2011 10:54 pm

Re: Ben's 2.x Laser Build

Postby BenJackson » Sun Aug 14, 2016 7:50 am

sliptonic wrote:Did you ever complete the transition to the mesa 5i25 card? I'm in the process of moving mine to that card and I'm wondering if you implemented a watchdog/charge pump.


Sorry for the super long delay in answering. I did finish converting to the 5i25, but I never used a safety charge pump signal. I also never followed through on my plan to get the FPGA to do a better job of rasterizing.
BenJackson
 
Posts: 518
Joined: Fri Apr 15, 2011 6:13 pm

Re: Ben's 2.x Laser Build Rides Again!

Postby BenJackson » Sun Aug 14, 2016 8:13 am

My laser cutter has been in storage since I moved a few years ago. I have access to a laser cutter (and a ton of other equipment) at work, so I haven't been in a big hurry. Unfortunately, it looks like I never actually took a picture of it bundled up for the move! I made some heavy cardboard corners for it, and protected the acrylic top with a 1/2" thick pink foam board the size of the whole cutter. Then I wrapped it up in that industrial saran-wrap stuff and covered it with "fragile" stickers. The axes were immobilized by rubber banding them against foam blocks and then pinching the MXL belts together so they couldn't move. The tube I pulled out and packed separately.

Lately I've been wanting to "quick turn" some laser cut stuff, so I decided to get it going again. I'm converting to DSP because I think I've gotten all the enjoyment I can out of the "controlling a laser cutter" hobby, and this time I want to focus on the "cutting things with the laser cutter" part of the hobby (or, actually, the "making things which happen to use some laser cut parts" hobby). I'm always surprised when I visit my laser build thread here and my cutter is basically done by page 3, and the rest of the 17 pages are mostly about EMC/LinuxCNC.

So I just bought an E5 from LightObject, and I've gotten as far as hooking up the axes and limits so I can poke at LaserCAD. This is some of the most Chinese firmware/software/documentation I have ever encountered. I'm intimately familiar with every aspect of stepper-based CNC control (see, e.g., most of this thread), and still they have managed to invent settings and terms that I can only guess at the meaning of. I spent an hour trying to figure out why everything gave me "beyond size" when it turns out that the default is to cut down/left from the origin, and the default origin is all the way down/left.

Anyway, I have axis control now (except Z will never go higher than the initial position, but there are still plenty of settings to grind through). As part of my plan to avoid the meta-hobby of building the cutter, I even gave up on my plan to re-use the zillion Pololu controllers I have and just bought the recommended ones from LightObject. You can see them in my picture, where they have replaced Bart's laser interface board.
Attachments
20160814_000025.jpg
BenJackson
 
Posts: 518
Joined: Fri Apr 15, 2011 6:13 pm

Re: Ben's 2.x Laser Build

Postby kbob » Sun Aug 14, 2016 4:08 pm

Good update, thanks. I have to move next spring, so I'll use your packaging tips.

The world needs a good open source laser cutter software package. LinuxCNC isn't it -- too much historical baggage.
Bob
"If you didn't code it, it will never own you." (-:
kbob
 
Posts: 149
Joined: Mon Jul 09, 2012 6:39 am
Location: Eugene, OR, US

E5 and Z axis

Postby BenJackson » Sun Aug 14, 2016 8:09 pm

My actual problem with Z is that the E5 hardware will not accept values < 1um/step for the Z axis. With all the gear reduction of the 2.x laser, it wants to be about 0.08. So I would put in the right value, it would show up in software, but if you did SAVE + READ you could see it was reset to 1. So my Z axis was going about 12x too slow, and with a 12x too small range.

The motor doesn't have enough starting torque at 1x microstepping (the only value that gets um/step just over 1) so right now I have the whole axis scaled up by 10x (using 8x microstep getting just over 1um/step), scaling up speed, accel, etc. Except the 600mm/axis limit kicks in, so my Z travel is limited to 60mm, which seems to be implemented as +/-30mm on each start. It's not fatal, but I'm hoping Marco at LightObject offers a better solution (I posted more detail on his forum).

(One more packing tip for kbob: When you unpack, you will find lots of tiny wood/plastic cutouts you thought you cleaned out, all gathered into whatever nooks and crannies are in the corners. I also found one T nut, which must have been loose in some slot. Make sure none of those end up in the electronics!)
BenJackson
 
Posts: 518
Joined: Fri Apr 15, 2011 6:13 pm

Getting ready for the tube

Postby BenJackson » Mon Aug 15, 2016 1:09 am

When I packed the laser, I remember thinking that I would only back out one screw, so that the other two would retain the alignment. But that was 3 years ago now, and I don't remember which one it was. And I vaguely remember that I had to back out another a bit when I was actually pulling the tube. These days I'm addicted to Microsoft OneNote, so I would have written that down!

Step one was to check that the aiming laser still worked, as a quick check that the mirrors were still where I left them. (See earlier in the thread for the red pointer laser that drops into the beam path when the door is open). I moved the carriage all around and verified that it still worked:
20160814_171857.jpg

I actually found my original alignment helper jigs, but I don't have the matching laser pointer anymore. So I printed a new set. These are rings with an OD that matches the laser. One has a pinhole (not as an aperture, but to help aim), and one holds a laser pointer. By aiming the laser pointer in the rear holder at the pinhole, it should force the beam to be parallel to the final position of the actual tube:
20160814_165903.jpg

20160814_172228.jpg

Here you see the guide laser dropped into the beam path being hit from behind by the jig aiming laser. The red arm with the guide laser was propped out of the way for the actual aiming (it also raises automatically when the door is closed).
20160814_172251.jpg

It's actually easier to verify the aiming of the laser pointer by looking at the back side of the front disc. It's probably even easier if you use a dimmer laser:
20160814_173204.jpg

Here's where it was hitting initially (the carriage is at the front right corner to get the longest beam path):
20160814_172429.jpg

And here's what it looks like with a little adjustment (also tested over the whole area of movement):
20160814_173417.jpg
BenJackson
 
Posts: 518
Joined: Fri Apr 15, 2011 6:13 pm

Re: Ben's 2.x Laser Build

Postby BenJackson » Wed Aug 17, 2016 5:37 am

It's funny how much I'm using my own build log here to remember how I did things before. I should have taken more detailed pictures, because I found myself wondering just how far forward I had the tube before, and how I had routed the water lines.

I wanted to make some progress today, so I wired the old front panel to the laser PSU for manual firing. I got the old water pump going and shot some holes in some paper. Aiming looks great all the way through the lens with no adjustments, so I'm pretty happy. I'm going to want to make sure the air assist tube is still coaxial with the beam. You can see a few posts (and years) ago where I found I was hitting the inside of it once before. If it happens again I'll probably chuck it in the lathe and drill it out a bit.

Even my few holes in paper made me remember how important exhaust is, so I'll probably get the flange back on (removed for the move) and set that up before I go any further. At work we have one of those super expensive self-contained filters (with layers of activated charcoal and this and that) and it's just not that effective. I'm glad I saw one in action before I was ever tempted to get one -- not worth it in my opinion.
BenJackson
 
Posts: 518
Joined: Fri Apr 15, 2011 6:13 pm

PreviousNext

Return to Build Logs

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests